0

I am new to this forum and I have the following issue:

Some days ago, I clicked on a pop up-window in my Linux-VM that said I need to Update some features or so ... after I clicked "Okay", my Comodo firewall gave me a warning that approx. read as follows: "VM.exe tries to access the protected COM interface" (This is a translation from German). And after I clicked "Okay" my Comodo bombarded me with a lot more messages which stated that chrome.exe (I have no chrome on my linux, only on my windows host system) and different other .exe-files tried to access the protected COM-interface. I then forced my computer to shut down by pressing the off-button and when I started it again, my desktop was totally blank and I could not access any programm and I could not even open the start menu with the windows button.

Starting my computer in safe mode works and a friend of mine advised me that comodo and avira are unneccessary tools that could cause me troubles so I tried to deinstall them. Avira deinstallation was successful while comodo deinstallation was not possible/failed, I can look up and translate the error message if that helps.

I planned to fix that error someday by reinstalling windows but until now it did not happen...

Now, I got me a new computer and I have worked with it for some days. First days no problem at all. But then, the following happened: I have an ova-file of my VM and and I imported it to the VM on my new computer. Yesterday, I opened my VM to work on a project for university (not for work! I do not get paid for this and there is no professional place at university where I could turn to with my problem), and then I got the same bombardment from my firewall like that one on my old computer, stating that different .exe-files try to access the protected COM interface. I immediatly forced a shut down on my computer and when I turned it back on, the VM was closed and my computer worked normally as before.

This happened yesterday. Since then, I have not opened the VM again bc. I am afraid of getting in trouble and having the same problems as on my old computer. I heard that it is hard for malware to infect the host system from the guest system, but might this be the case in my situation? Maybe it's also improtant to say, that there existed a shared folder between my windows and my linux system and that yesterday, before the COM interface incident happened, I got an advice from my linux, that my shared folder does not work or something like that (it was a notification about my shared folder, I don't really remember what it exactly was...).

Thanks for your help in advance!

Pedro

1
  • When COMODO warns about accessing a protected COM interface it's doing its job. You've probably configured it to be a lot more interactive, and give you options to intervene. When you rebooted and had no ability to do anything, you might have blocked something and ticked "remember". Did you try Ctrl-Shift-ESC to start task manager? The next place I would look is its audit trail - if this isn't switched on, do so and then a normal reboot. Your friend can make a comment about software firewalls being unnecessary, but only you can decide the extent to which you want to control your own devices.
    – brynk
    Jan 27 at 11:47

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.