My browser (Vivaldi) does not send any accept-language or similar headers for my native language.

Its user-agent does not contain my country or preferred language.

My proxy is verified at https://ifconfig.co/json to be in Netherlands and nothing about it hints at it being located in my actual country, which isn't even geographically close.

Before trying this again before asking this question, I have fully deleted all browser data.

My actual location is not USA, Germany or any other "default" location. It's a minor country.

Yet, in spite of all this, when I go to https://www.storz-bickel.com/ , the "geoip" (that's what they call it in the HTML) region auto-picker in a couple of seconds switches from nothing to my actual country.

I have gone through all the settings of the browser and removed anything such as "WebRTC" leaking my real IP address, and I have uBlock Origin to aggressively block all kinds of trackers which could possibly be telling the site some sort of historical data about my actual location.

This seriously freaks me out. How could they be figuring this out?

  • g'day, there's a couple of possibilities, one in particular: via your dns resolution - 1st review github.com/gorhill/uBlock/wiki/Blocking-mode:-hard-mode to ensure blocking of all 3rd party ; visit coveryourtracks.eff.org and do the test (don't modify the uBo settings) beforehand - the point is to test your default config
    – brynk
    Jul 3, 2022 at 0:58
  • depending on the results of the eff test, you might also consider the use of trr aka doh (dns-over-https), which can be made to force all your browser lookups to be resolved via a 3rd-party service - more: cloudflare.com/ssl/encrypted-sni/#results (ps. i don't necessarily recommend using - you can search for other options and decide if you want to go down this path, but if you do, consider using the mozilla endpoint as it is claimed to be audited for adherence with the privacy agreement - support.mozilla.org/en-US/kb/firefox-dns-over-https)
    – brynk
    Jul 3, 2022 at 1:10
  • another resource - browserleaks.com - another possibility is that your device hardware may have been fingerprinted previously (before your browser was configured to a more privacy-oriented stance) and the lookup is coming straight out of their cache
    – brynk
    Jul 3, 2022 at 1:13
  • also depending on what browser you're using you might need to review your overall instal to ensure that geolocation-lookups are correctly disabled, have a read of: comparitech.com/blog/vpn-privacy/… as a prelim guide (pay particular attention to any wifi grants) and always remember that wifi triangulation can potentially pinpoint you sitting at your dinner table (what-three-words is that!?)
    – brynk
    Jul 3, 2022 at 1:28
  • Is this reproducible in a private browser tab? Your timezone could be used to identify you. In Linux I solve it by running my web browser this way: TZ=UTC firefox This web site doesn't identify my real location - shows the country of my VPN provider instead. Jul 3, 2022 at 11:14

2 Answers 2


From information that you provided, it's hard to say what exactly is the reason for your location leakage. You can try following:

  1. Change browser or use incognito mode
  2. Sign out from account and check for location settings (inside your profile)
  3. Open https://browserleaks.com/ and try to identify your browser behavior

There are other ways to get someone's geolocation other than HTTP headers and preferred languages, for example, if you have JavaScript enabled on their site, they will be able to see your device's timezone and use that to tell where you're living.

To make sure, you can try it on Tor Browser (which enables the resist fingerprinting feature and changes your timezone to UTC0) and see if your geoloaction changes to the United Kingdom or not.

Note: if you're using Firefox or a firefox based browser, you can go to about:config and enable privacy.resistFingerprinting to change your timezone to UTC0 (resist fingerprinting does alot more to prevent fingerprinting, you can learn more about it here).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .