I created an unshadowed file to run through john, it worked fine. I created some additional users and created a new file with those hashes in there. I run john and get

Using default input encoding: UTF-8
No password hashes loaded (see FAQ)

I have read through several threads and not found the answer. I ran file -i on the first file and it's us-ascii. I ran the same command for the second file, us-ascii. When I try to run the second file through john I get the above error. What am I not seeing? Why does the first file work and the second does not? How do I fix this?

  • 1
    Without seeing the file, we can only guess. Have you checked the whitespace? Was the original file a single line, and now there are multiple lines?
    – schroeder
    Jul 29, 2022 at 19:07
  • both files have multiple lines, I would upload the files but I'm new here and don't see where to do this. The files should technically be the same, except for the added users at the bottom. The process to create each file was unshadow /etc/passwd /etc/shadow >unshadowed also used /etc/passwd /etc/shadow >~/unshadowed .
    – Kris
    Jul 29, 2022 at 19:30
  • 1
    As I said, without seeing the files, we can only guess. Copy/paste the new lines and use the code formatting tool?
    – schroeder
    Jul 30, 2022 at 17:22


You must log in to answer this question.

Browse other questions tagged .