1

First off, please don't turn this question into a LibreSSL vs OpenSSL holy war! I'm just trying to understand the functional differences between them, nothing more.

I originally asked this question on SuperUser but I think it's more relevant here.

I've encrypted a file on an Amazon Linux 2 VM using the default installed OpenSSL version (OpenSSL 1.0.2k-fips) like so:

openssl aes-256-cbc -salt -out ~/my_file.txt.enc -pass pass:[redacted]

However when decrypting the file on OSX using the default installed OpenSSL version (LibreSSL 3.3.6) using the command below, I keep getting "Bad Decrypt".

openssl aes-256-cbc -d -salt -in ~/my_file.txt.enc -pass pass:[redacted] > my_file.txt

Firstly, are there differences between the decryption process for aes-256-cbc on LibreSSL and on OpenSSL, or have I got something else wrong in the decryption process?

Secondly, if there are differences in the encryption/decryption process is it possible to run both LibreSSL and OpenSSL on OSX?

3
  • 2
    Have you seen this SuperUser question? Feb 15, 2023 at 9:50
  • I haven't. I've tried manually specifying the digest algo to use for the decrypt but still get "bad decrypt" for md5 and sha256.
    – MorayM
    Feb 15, 2023 at 11:29
  • See this answer.
    – mentallurg
    Feb 15, 2023 at 13:14

0

You must log in to answer this question.

Browse other questions tagged .