0

I have a .dmg file on my MacBook. I have forgotten the password of the .dmg file and now I'm not able to access the files in it.

I tried using John the Ripper. However, whenever I run john --format=dmg-opencl (*insert filename here), I always get the error "No password hashes loaded (see FAQ)".

I tried saving the hash in .txt file format. The file contained what does not look like a hash (series of letters and numbers) but it looks like a directory.

I think the issue is the hash file that is not properly created.

Please help in cracking the password of my .dmg file.

1
  • "I tried saving the hash in .txt file format. " -- what does that mean? what did you do? How did you create the hash file? "insert filename here" -- what file did you supply?
    – schroeder
    Jul 12, 2023 at 11:29

1 Answer 1

1

You need to extract the hash from the file and then run john on the extracted hash.

You can use dmg2john to do that. If that does not work, could you share a snippet of the file you're passing to john? Just the output of xxd <filename.dmg>| head.

I've found a guide for you here: https://calvin.me/cracking-passwords-on-macos/

1
  • Apologies, I missed this. I still haven't retrieved my files. How do I share a snippet of the file?
    – ange1o
    Oct 19, 2023 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .