0

I'm currently testing a mobile app (suppose it communicates with the domain blablabla.net).

For the purposes of testing this app, I've set up an android machine on another netowrk, and I'm currently trying to set up burpsuite from my local machine to proxy it. Here's what I tried:

  1. Start burpsuite on port 8080 on my local machine
  2. Use an HTTP tunnel, so that when I visit a domain like bbb.tunnel.com, the request will get forwarded to burp
  3. Set the proxy in Firefox to bbb.tunnel.com port 80 (I'm testing it in Firefox first, if it works, I'll do the same thing in the android machine)

But when I do this, I just get a bad gateway error whenever I connect to a site.

How can I solve this?

The tunnel is forwarding to port 8080 on my local machine where burp is listening, and when I visit the tunnel's domain I get the homepage of burp (So the tunnel works) but the proxy itself doesn't work.

5
  • I think we're missing some details. Where is there a tunnel? Is the EC2 instance invovled at all? Can you explain the network paths more fully?
    – schroeder
    Oct 22, 2023 at 19:03
  • The tunnel is forwarding to port 8080 on my local machine where burp is listening. When I visit its domain I get the homepage of burp (so the tunnel is working), but the proxy doesn't work, and the EC2 instance isn't involved yet.
    – sag0li
    Oct 22, 2023 at 19:08
  • Please edit the question to provide the full details. Please avoid including irrelevant details. If EC2 isn't involved, there is no need to mention it.
    – schroeder
    Oct 22, 2023 at 19:10
  • What do you mean by an HTTP tunnel? What exact software and configuration have you used to set this up? I've configured mobiles to forward through Burp many times and the two most common problems are the host firewall on the laptop, and the WiFi router not allowing peer-to-peer communication, both of which can be fixed with config changes.
    – paj28
    Oct 22, 2023 at 20:47
  • I used tunnelmole: github.com/robbie-cahill/tunnelmole-client With the command tunnelmole 8080
    – sag0li
    Oct 22, 2023 at 22:15

1 Answer 1

0

Perhaps you need to enable "invisible proxying", here:

invisible proxying in Burp

Normally, Burp is configured as a proxy, and receives proxy traffic. If you use port forwarding or something like that to redirect traffic to Burp, the application/browser talks to Burp as if it is the webserver, not as if it is a proxy. Burp can handle that, but you need to enable it.

Instead of using port forwarding, it is also possible to configure Burp as a proxy on the Android device. When connected with Android Debugger (ADB), the following command configures the proxy:

adb shell settings put global http_proxy 1.2.3.4:8080

I have some more tips about intercepting Android traffic on my blog.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .