2

i have a question many people asked in the last years but there seem to be no answer. So i will reask that.

i am running "airodump-ng --essid [MyAP] -c [MyAP-Channel]" and getting no info about connected stations.

I do receive some unassociated devices but my own devices don't show up and there should be at least 3 active.

There should be said, that if i am starting a hotspot on my smartphone and connect my laptop to it, i do see my laptop listed under stations with a corresponding "Frames" count.

Because many of the questions are already years old, i would guess that there isn't some special technic to hide connected stations remotely by configurations made in the AP or something.

There is a chance that my driver is not properly installed but this behaviour is tested with 2 different network cards from different manufacturers on different devices.

Same questions:

4
  • A warm welcome to the community. Is your wireless adapter in monitoring/promiscious mode? Jan 7 at 13:50
  • @Sir Muffington It is indeed in monitor mode.
    – Yuki
    Jan 7 at 17:17
  • Perhaps your router is jumping between 2.4GHz, 5GHz and 6GHz or is in a freq (i.e. 6 GHz) which cannot be seen by the adapter. On your device side what do you have? Perhaps it doesn't support monitor mode or the driver doesn't support it Jan 8 at 20:04
  • @Sir Muffington the most simple reason. It is very likly the 5Ghz band..
    – Yuki
    Jan 9 at 20:27

1 Answer 1

0

The issue might lie with the monitor mode adapter residing on the 2.4Ghz frequency while the AP is running both 2.4Ghz and 5Ghz, most clients will automatically use the 5Ghz frequency band. In most routers the 5Ghz band can be disabled, this should force the clients to reconnect to the 2.4Ghz network band allowing them to be spotted by the monitor mode adapter.

1
  • Yes thanks, so simple but overlook. It is just operating on a different band. I was still used to it beeing different access point entries on my nic..
    – Yuki
    Jan 9 at 20:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .