-9

Is there a way to install Metasploit under Cygwin? Metasploit is meant to be run under a linux environment.
The Windows installation doesn't have many tools such as msfpayload available.
Please contribute with an answer, not alternative methods.

  • 2
    Install a linux virtual instance to run it? – David Houde May 17 '13 at 6:15
  • Why would you install a linux virtual instance if it runs natively Windows :P? – Lucas Kauffman May 17 '13 at 6:18
  • 1
    He mentioned that the Windows version is missing some features. I cannot verify this claim though. I think if the desired result was to run the linux version, he may have better luck with a VM instead of Cygwin. – David Houde May 17 '13 at 7:52
  • @DavidHoude Thanks, finally somebody has noticed my point. – DarrenVortex May 17 '13 at 22:11
5

Metasploit is meant to be run under a linux environment.

Wrong. Metasploit is simply a collection of Ruby scripts, so all you need is Ruby installed. Also, Metasploit has a Windows installer so go crazy with it...

  • I'm aware of the of the windows installer but it doesn't have many tools such as msfpayload available. – DarrenVortex May 17 '13 at 5:52
  • 1
    then download virtual box and learn linux. I know that sounds harsh but really that's probably the best route. Linux is free and so is virtual box. – Jason H May 17 '13 at 19:29
  • 1
    virtual system is extremely un-memory-efficient and uses too many resources to run metasploit. There are also always networking problems especially with virtual box which can't emulate NIC. – DarrenVortex May 17 '13 at 22:18
0

No, or at least we don't know of a way to accomplish what you're asking as of now.
However, we do recommend that you install a virtual linux system and run metasploit that way.

Not the answer you're looking for? Browse other questions tagged or ask your own question.