1

I'm attempting MAC spoofing on a network I own. I'm connecting to a NETGEAR WNDR4300 wireless router from an Ubuntu Linux machine. The network uses WPA2-PSK [AES] security.

Connecting to the network with an un-spoofed MAC works fine. I can bring my network interface down with

sudo ip link set dev wlan1 down

and then spoof my MAC with either

sudo macchanger -e wlan1

or manually with

sudo ip link set dev wlan1 address XX:XX:XX:XX:XX:XX

(picking some address). Both techniques work. When I bring the interface up with

sudo ip link set dev wlan1 up

it attempts to reconnect to the network, then prompts me for the password. I enter the correct password, but it fails to connect. I've tried this numerous times, with various MACs (random, same vendor, etc.), without success.

What's going wrong, or how can I diagnose the issue?

  • Can you try restarting your router as well? – Kerim Oguzcan Yenidunya Sep 12 '13 at 8:27
  • @KerimOguzcanYenidunya - I'd really rather not; the router is working perfectly and handles every connection request from every device. I suspect this may be an Ubuntu bug as AdnanG suggests, but am still investigating. – TrueWill Sep 12 '13 at 16:34
1

You might find the solution to your problem in this answer on superuser:

Some more information on a big related to your issue here.

  • Please don't post an answer with just a link. Include the relevant content from the link. For more tips on writing answers, read How to Answer. – Gilles Sep 12 '13 at 12:07
1

If the above answer doesn't help, if I remember correctly this router has the ability to perform MAC address filtering (?) you may want to check that this is either turned off, or compatible with the MAC address you are choosing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.