0

I am using ZAP 2.2.2 and I have generated a dynamic SSL certificate and added it to my Firefox browser. I then started a proxy on localhost with port 8090 and configured Firefox to use it. When I browse https://google.co.in it works, i can see the result in "Sites" tab. When I try to browse http://google.co.in it gives an error: zap Error: Address family not supported ny protocol family: connect. How can I solve this error?

screenshot

1

The error you're getting would appear to be from the underlying Java runtime as opposed to being something specific to ZAP.

Java 7 does sometimes appear to cause odd SSL issues, so as a first step in troubleshooting, you could try installing Java 6, run ZAP with that and see if that resolves your issue.

Alternatively you could try a suggested fix from here and specify

-Djava.net.preferIPv4Stack=true

when you launch zap

1

All of these sites work fine for me using ZAP 2.3.1 so could you try using that?

FYI we have a ZAP Users group which is probably more suitable for questions like this: http://groups.google.com/group/zaproxy-users Thats linked off the ZAP "Online / ZAP User Group" menu item, which is apparently invisible as no one seems to spot it ;)

Simon (ZAP Project Lead)

0

The HTTP verb connect means that your browser is trying to establish a secured HTTPS connection to Google. This is because Google is redirecting you from the HTTP url you typed in your browser to the HTTPS service for this URL, and there seems to be something going wrong during this redirect (HTTP 302).

Try changing your browser's user-agent, for example using this Firefox extension. Set it to a random string and then try again to access the HTTP URL.

Also note that Google don't allow HTTP connections when you are signed in. To access HTTP URLs, you have to be signed out.

See also the following links for additional information:

  • its not problem with google, i tried many other sites with out https it does not work, for example i tried lifehacker.co.in but still same error, instead of lifehackerco.in i tried many other sites but i am getting same error. – yogesh.panchal Mar 3 '14 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.