0

Using Metasploit I am trying to attack an unpatched Windows XP SP3 Virtual machine with the ms08-067 exploit but it just gets stuck at Attempting to trigger the vulnerability. I assume this means the exploit failed for some reason but I would like to make it work. Do I need to enable any GPO or some other change on the target for the exploit to work?

I have checked the following:

The targets firewall is turned off and has no defences.

I have checked in add remove programs with the show updates box ticked and there is no patches.

The target IP address is correct.

Port 445 is open.

2
  • 2
    Have you tried running "check" instead of "exploit". That checks to see if the system is vulnerable. If that doesn't work then you probably are having communication issues between systems. Try auxiliary/scanner/portscan/tcp to see if one system can touch the other. – mubix Sep 29 '14 at 15:14
  • I ran nmap -p 445 -script smb-check-vulns -script-args=unsafe=1 192.168.1.120 and it reports the system is not vulnerable even though it's an out of the box XP SP3 system. Check reports the same, I can ping the target and browse to it. – Ninja2k Sep 29 '14 at 15:19
1

I got this working by changing my target machine to Windows XP SP2.

3
  • So, is this the answer? Are you satisfied with your workaround? – schroeder Sep 29 '14 at 18:00
  • Yes as long as I can run the exploit and learn how it works I am happy. I was following it from a book so I needed it to work to proceed to the next lesson. – Ninja2k Sep 30 '14 at 14:04
  • I need to wait another 22 hours before it lets me. – Ninja2k Sep 30 '14 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.