-1

I type iw list and these are the supported modes:

Supported interface modes:
                 * IBSS
                 * managed

When I run hostapd hostapd.conf I get this:

Failed to create interface mon.wlan0: -95 (Operation not supported)
Could not set channel for kernel driver
wlan0: Unable to setup interface.
Could not connect to kernel driver.

I have also tried this other path:

airmon-ng start wlan0

airbase-ng -e FreeWifi -c 11 -v wlan0

With this result:

ioctl(SIOCSIWMODE) failed: Operation not supported

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
Sysfs injection support was not found either.

In case that helps for the troubleshooting my card is this one:

lspci | grep -i net
00:19.0 Ethernet controller: Intel Corporation 82566DM-2 Gigabit Network Connection (rev 02)
01:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)

Thank you very much

1
  • Are you running those as root? In any case, you seem to be using the wrong interface. After you run the "airmon-ng start wlan0" command, you should see "mon0" interface being created. Any subsequent commands should use that instead of wlan0. Oct 31 '14 at 5:34
1

In order to act as a proper access point, your card needs to support "master"/"AP" mode. You can fake it if the card supports "monitor" mode with packet injection (in this case, your AP software will be performing many of the tasks that the driver/card would be performing in "master" mode), and you can get some of the functionality of an AP if your card supports "ad-hoc" mode (set up an ad-hoc network and configure your computer to route between the wireless and wired networks).

0

When I perform iw list I have a third option, monitor.

Supported interface modes:
     * IBSS
     * managed
     * monitor

I think this is what your IOCTL failure is stemming from. Your wireless interface needs to have a monitor mode. Try the following command (as root) to enable RFMON and I believe it will fix your problem.

iwconfig [interface] mode monitor

6
  • operation not supported
    – aDoN
    Oct 30 '14 at 12:12
  • Does your interface come up at all? It sounds like you have a driver issue.
    – RoraΖ
    Oct 30 '14 at 12:14
  • Yes ifconfig wlan0 up works (I fixed that problem before)
    – aDoN
    Oct 30 '14 at 12:17
  • 1
    You might want to reinstall the Broadcom drivers, using Ubuntu?
    – RoraΖ
    Oct 30 '14 at 12:20
  • I recently reinstalled them, I am using Debian 7
    – aDoN
    Oct 30 '14 at 12:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.