Any domain that cannot be resolved defaults to yandex right now, on any browser on my system.

Helper objects or extensions are not installed.

It turns out that the ISP (Turk Telekom) is employing DNS Poisening to achive this result. All pages that cannot be resolved now resolve to the yandex landing page.

Yandex Spamming my browser

  • 1
    I would guess you missed something in the installation that allowed it to do so. Programs can be sneaky some times. Gotta be careful of user agreements. – RoraΖ Nov 12 '14 at 12:22
  • "access and change this without a user knowledge" - because you've explicitly installed a program (anti-virus) which is designed to interfere with your access to the net. – symcbean Nov 12 '14 at 12:45
  • @raz: well I repeated the installation before I wrote that and also checked the TOS agreement, no reference to yandex or the browser at all. – Herr Nov 12 '14 at 12:51
  • @symcbean yeah but I would still like to keep my personal preferences – Herr Nov 12 '14 at 12:51
  • @HerrK You're absolutely sure it's the AV? Uninstalling it gets rid of the Yandex change? – RoraΖ Nov 12 '14 at 13:01

When the default DNS server of your internet provider doesn't give you the results you expect, you could set a different one in your operating systems network settings.

Here is a list of IP addresses of public DNS servers.

When you need help with setting a DNS server in your operating system, consult the appropriate stackexchange.

  • That's already the case right now, but it's still very rude to do this by default with no way to opt out. – Herr Nov 12 '14 at 18:21

It turns out that the DNS system has been hijacked by yandex in cooperation with turk telekom (TTNET) which in turn results in non resolving pages end up on the yandex landing page.

Not the answer you're looking for? Browse other questions tagged or ask your own question.