0

I'm suspicious. I wanted to forward a port (80) on my router and noticed that port forwarding didn't work properly, it didn't work at all.

So I replaced the router and again, port forwarding was not working.

There are no firewalls running and everything is configured as it needs to be, the only thing not working is the port forwarding on the router. I've tested the range from 0-1024 and also tried to forward the port range over 20000, which didn't work.

  • Under which circumstances would an ISP level blocking or preventing of port forwarding happen?
  • Is it possible that the traffic is routed through some device that would prevent this kind of port forwarding?
  • Is this realistic or just a little bit too paranoiac?

Thank you

closed as off-topic by schroeder, Xander, TildalWave, Scott Pack, SilverlightFox Jan 11 '15 at 11:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – Xander, TildalWave, Scott Pack
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Why is this tagged nsa? – cpast Jan 9 '15 at 8:32
  • Did you call your ISP and ask? It's what they are there for. – GdD Jan 9 '15 at 8:54
  • @cpast I removed the nsa tag and added port-forwarding instead. – Philipp Jan 9 '15 at 9:15
  • 3
    Can you check the IP the router gets from the ISP ? If it's a private address, you might be behind a CGN which would prevent you from port forwarding. – user2313067 Jan 9 '15 at 17:40
  • Perhaps your ISP doesn't allow initiating connections to your IP? – schroeder Jan 9 '15 at 18:44
1

ISPs cannot block port forwarding. Port Forwarding is an action of a service. They can block ports, and initiating connections incoming to your IP.

In order to troubleshoot, you will need packet traces before and after your router. This is not an InfoSec problem, this is a basic networking problem.

  • Is there abslute no probability that there might be something fishy in this? – Herr Jan 10 '15 at 5:53
0

Some ISP's block traffic to ports that are known to be scanned by bots regularly. In Belgium for example, there was a time that ISP's blocked all traffic going to ports 0-1024. Currently that is not the case anymore (since a year or so). Maybe in your country/ your ISP still does that?

Are you sure you can reach port 80 on your router?

Note: this is usually only the case for private subscriptions. If you have a business subscription with your provider, ports were/are never blocked.

  • I've tested the range < 1024 and > 10000 which both didn't worked. I can reach the internal ports on the network IPs and I also tried several devices from web server to terminal, which didn't work :( – Herr Jan 9 '15 at 7:46
  • Well, your ISP has no way of knowing whether you are port forwarding or not (unless the router is controlled by your ISP, which I suppose is not the case as you mention that you replaced the router). So no, your ISP cannot be blocking port forwarding. Are you sure your settings are correct? – Michael Jan 9 '15 at 8:05
  • I'm doing this for years and this is the only time I'm failing at forwarding ports. – Herr Jan 9 '15 at 9:21
0

Most internet service providers do not allow people on a private subscription to host servers. A few enforce this by blocking the ports used by typical server applications.

When you want to know if your ISP does that, call their support hotline.

  • Well I've also tried non-common ports and it didn't worked. They also they have no policy on that. – Herr Jan 9 '15 at 9:20
  • @HerrK In that case you might want to ask on superuser.com if you maybe do something wrong when trying to enable port forwarding. – Philipp Jan 9 '15 at 9:22
  • well it's related to a suspicioun so I think this place is better. Thank you – Herr Jan 9 '15 at 10:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.