By default, Burp Suite is able to intercept the request from the page, but not getting the JSON response. What rule should be added in the 'Intercept server responses' menu (in the 'Proxy > Options' tab) to be able to edit the JSON responses received from the server.

closed as off-topic by schroeder, Stephane, TildalWave, M'vy, RoraΖ May 4 '15 at 11:44

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – schroeder, Stephane, M'vy
If this question can be reworded to fit the rules in the help center, please edit the question.


BurpSuite will not intercept server responses by default and display them to you.

To enable this functionality go to:

Proxy -> Options -> Intercept Server Responses

And make sure to check the box next to

Intercept responses based on the following rules

Then either select one of the displayed rules or add one like the highlighted one below:

Enable Intercept Server Responses for Json Responses

Also make sure to enable Intercept in the Intecept-tab.