0

My university internet connection runs behind proxy. Its host name is 192.168.1.103 and port no is 3128. How do I configure proxy in burp suite if I should enter above proxy setting in my Firefox browser?

Following method I have tried but fails:

I have set manual proxy as "127.0.0.1:8080", but my browser could not load any site after that proxy change.

5

Configure your browser to point to Burp's proxy details (e.g. 127.0.0.1:8080) and then configure Burp to use an upstream HTTP proxy for all target hosts (* as the destination):

Burp upstream proxy

However, if the upstream proxy is SOCKS, not HTTP, you need to configure it underneath (under the SOCKS Proxy heading) instead. This causes everything to be fed through the proxy. At the moment, Burp doesn't support per-target SOCKS proxies, but this shouldn't affect your situation.

For more information about Burp's capabilities, go to Help -> Burp Suite Help. Information about proxy settings can be found in the Suite Options -> Connections section of the help.

  • @ManojVarma No probs. Don't forget to mark as accepted. – Polynomial May 8 '15 at 23:24
  • This seems to have changed in the latest version, and this functionality has been renamed. Is it possibly the "redirect" property in the Proxy Listeners section? I can't get this to work at all – JLo Jul 19 '18 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.