-4

Just going to say this right now; this seems absolutely ludicrous.

I've had a problem with playing Super Smash Bros. on Wii U ("Cannot connect to partner's device."; also happens for all Internet-based games [Splatoon, Monster Hunter 3, etc.]) Nintendo's support decided it'd be good for opening ports 1-65535. To make matters worse, my router's port forwarding does not let me port forward things for certain device. I can only open ports to ALL my devices. If anyone has a better option with the same effects, or could just generally give me a risk ratio, that'd be perfect.

-Matt

P.S. The Wii U uses peer-to-peer connections. There's no servers for games. You have to trust seven different people that their Internet is good enough to connect to a locally-hosted group.

closed as unclear what you're asking by Xander, Lucas Kauffman, ThoriumBR, M'vy, Stephane Jun 1 '15 at 8:39

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Your question is unclear, I suggest to extend it. What is SSB4? What is "Ninty"? – peterh May 30 '15 at 2:32
  • 1
    Yes, needs clarifying. Regardless, any suggestion to open all ports from 1 - 65k is a support suggestion to be ignored. Any service which provides support answers like that is not a service you want to use. – Tim X May 30 '15 at 5:28
  • 1
    It doesn't make sense to forward ports to ALL devices, that's like trying to park a car in two car parks at the same time. What make/model router is it, and have you looked for instructions on portforward.com ? (Forwarding all ports is probably not necessary if the problem is you connecting to a partner device. Look for logs on the router that might show you specifically what is being blocked). @peterh Super Smash Brothers 4 (SSB4) is computer game, on a Nintendo Wii-U game console - so "Ninty" is presumably Nintendo. – TessellatingHeckler May 30 '15 at 7:38
  • @TessellatingHeckler I'll probably check my logs now. – mattycfp May 30 '15 at 15:10
1

Ninty's, support decided it'd be good for opening ports 1-65535.

When they get to this option on their list of things to try, it means they really have no clue what is wrong with your setup. I admire your patience for getting to the last level of the technical support line.

To make matters worse, my router's port forwarding does not let me port forward things for certain device. I can only open ports to ALL my devices.

You can only port forward a given port to one device. The port will not be "opened" for other devices on your local network, because there is only one IP to receive connections; your devices do not have separate public IP addresses that they could individually be reached at from the outside.

If anyone has a better option with the same effects, or could just generally give me a risk ratio, that'd be perfect.

But what effects would these be? I'm not sure that "opening ports 1-65536" on your router would even do anything. If an inbound connection for, say, port 80 comes in, where does it go if that port isn't configured for port forwarding? Probably nowhere anyways.

  • I've heard of VPNs and the such being protective while also having these ports open. That's something I would mean by "other options." My router (Belkin, cannot find current make or model) only supports the port forwarding of all devices. There's no "choose which device IP you wish to port" option. – mattycfp May 30 '15 at 14:58
-1

Found an answer at last. I talked to Nintendo Support; just go to the Nintendo Chat Support and ask for help with any issues regarding those ports. They'll remote control your computer and fix the problem. Took me many tries to get someone who would do this, but I got lucky on number 7. While I can't see what they did right now (on a trip), I believe they disabled the firewall, opened the ports, got it working, then enabled the firewall again and closed the ports. Why this worked, no idea.

  • This doesn't provide an answer though - what did they actually do? – Rory Alsop May 31 '15 at 18:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.