2

The software I use to generate my PGP keys doesn't include the 'Version:' line that most PGP software includes by default.

Almost every public key I've seen begins like this:

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.4.9 (GNU/Linux)

But mine doesn't contain the Version: line.

Will this cause any problems (compatibility/decryption/etc. issues)?

0

The Version header is purely informative; my guess is that it's included to make compatibility bugs easier to discover (e.g. if a client is unable to decrypt 10 messages, and all 10 were made by the same version).

Source: https://superuser.com/a/823907

Not the answer you're looking for? Browse other questions tagged or ask your own question.