1

I am currently running a setup that interfaces with many appliances running HTTP servers (running on Windows Embedded). The connections I use are HTTPS connections. My problem is, every time I open the web portal of those appliances (simple HTTPS servers that display some info), I get a "There is a problem with this website's security certificate" warning.

I have tried adding that certificate to the Trusted Root CA certificates, but I still get that prompt. I tried doing it from IE directly, and from certmgr.msc (after exporting the certificate file) with the same unsuccessful result. No matter what I tried, I still get that prompt.

Is there anything I might have overlooked ?

EDIT: Requested screenshots

enter image description here

enter image description here

  • 1
    Can you post a screenshot, or provide a more detailed description of the error you see? – RoraΖ Jul 20 '15 at 14:38
  • Added screenshots in original post. – Wassim Jul 20 '15 at 14:42
1

The error message

The security certificate presented by this website was issued for a different website's address

indicates that the URL that is embedded in the cert is different from the URL that you are typing into the address bar of your browser. Once you put a cert on a server, browsers will only let you access it through its full public domain name (as a defense against man-in-the-middle attacks).

Are you trying to access your server by its IP address or by a local hostname?

  • I am accessing it through its hostname. smc0010f334747c/ui Should the full URL be in the CN ? or the hostname only ? – Wassim Jul 20 '15 at 14:53
  • If you type "The security certificate presented by this website was issued for a different website's address" into Google, you will get many guides that help you solve your problem. – Mike Ounsworth Jul 20 '15 at 14:57
  • Okay so, I think my issue is that the CN is SMCXXXXXXXXX (something I have no control over, I think). The wildcard character for CNs seems to be *. – Wassim Jul 20 '15 at 15:04
  • @Wassim Glad you found your answer. I guess you'll have to re-issue your cert using proper wildcards (or using the exact hostname if you want to get it working quickly). -- Or you could set the hostname of the server to "SMCXXXXXXXXX" to make sure that this is actually the problem. – Mike Ounsworth Jul 20 '15 at 15:07
  • 1
    As a test, I renamed the hostname on one of my appliances to SMCXXXXXXXXX and the message went away. So you were all right, I need to re-issue the certificates with the correct CN. Thank you all for the help. – Wassim Jul 20 '15 at 15:26
0

The certificate generates an error because the CN you provided is different from the URL you are using in the browser.

To solve the problem, you would have to re-issue the certificate with the correct name. You can also add Subject Alternative Names in the certificate if needed (e.g. you have an internal address and an external address for the appliance).

  • Thank you for your answer. My CN is : SMCXXXXXXXXXX, and the URL is smc0010f334747c/ui/LogOn?ReturnUrl=%2fui Shouldn't the X's be used as wildcards ? – Wassim Jul 20 '15 at 14:50
  • Well it should be the URL you're connecting to. Wildcard should also be usable. – M'vy Jul 20 '15 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.