A side-channel vulnerability affecting modern microprocessors that perform branch prediction like Intel, AMD, ARM, Sparc and PowerPC allowing user processes to read memory belonging to other processes. Affects Linux, OS X, and Windows. Published in January 2018.

A side-channel vulnerability affecting modern microprocessors that perform branch prediction like Intel, AMD, Sparc V9, ARM and PowerPC CPUs allowing user processes to read memory belonging to other processes. Affects a wide range of OSes like Linux, OS X, AIX, Solaris and Windows. Published in January 2018.

The attack exploits speculative instruction execution that results from CPU branch prediction, coupled with traditional cache timing attacks in order to learn the contents of another process' memory space.

See full attack details at https://spectreattack.com

See our canonical question on this site at Meltdown and Spectre Attacks

history | excerpt history