I cross-posted this on the manjaro forums and on server fault. So far no answer, so trying here.

I have gnome-keyring running for sure, not sure it's gnome-keyring or gpg-agent or ssh-agent related...

I use pass as command line password manager for many things. Usually, when querying pass, a dialog would appear asking me to enter a password first. I assume it was gnome-keyring asking me for my password. It may well be gpg-agent or ssh-agent - I don't know.

However, since some time ago, it does not ask my password anymore - thus, anyone with access to my shell can use pass to see my passwords, as they are printed on STDOUT. I must have clicked on the option to somehow save my password I guess.

I want to enable pass to ask me for my password again. How do I do that?

1 Answer 1


You should check if either or both the gpg-agent or gnome-keyring daemons are running. Some display managers will automatically start gnome-keyring. I've never used it. gpg-agent is a separate daemon and can sometimes cause conflict.

In ~/.gnupg/gpg-agent.conf, you can declare to cache your gpg key password for a period of time. My config reads:

pinentry-program /usr/bin/pinentry
default-cache-ttl 60480000
max-cache-ttl 60480000

Which will cache the password for the maximum amount of time. I use the /usr/bin/pinentry GUI application to pop-up and ask for the password the first time something like pass asks for it. This would not work on a headless system; I think by default it just asks on the command-line.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .